GoCardless IBP UK / Cater Allen is unavailable for instant payments
Monitoring·Degraded performance

The incident has been resolved and we are monitoring the situation.

Fri, Oct 3, 2025, 07:04 PM
(1 day ago)
·
Affected components
Cater Allen
Updates

Monitoring

The incident has been resolved and we are monitoring the situation.

Fri, Oct 3, 2025, 07:04 PM

Identified

We have identified an issue with GoCardless IBP UK / Cater Allen and have removed them from the institution list.

Fri, Oct 3, 2025, 03:40 PM(3 hours earlier)