Barclays downtime
Resolved

Barclays have successfully resolved their issues and are now available again in the list of institutions for Instant Bank Payments.

Sun, Aug 10, 2025, 09:35 AM
(1 week ago)
·
Affected components

No components marked as affected

Updates

Resolved

Barclays have successfully resolved their issues and are now available again in the list of institutions for Instant Bank Payments.

Sun, Aug 10, 2025, 09:35 AM

Monitoring

Barclays have successfully resolved their issues and are now available again in the list of institutions for Instant Bank Payments. We will monitor to ensure there are no further issues.

Sun, Aug 10, 2025, 09:06 AM(28 minutes earlier)

Investigating

We are still seeing failures for IBP regarding Barclays. As a result, Barclays will not appear on the list of institutions for Instant Bank Payments (on the payer’s side). We are monitoring the situation and will update at the earliest.

Sun, Aug 10, 2025, 07:58 AM(1 hour earlier)

Monitoring

Barclays have successfully resolved their issues and are now available again in the list of institutions for Instant Bank Payments. We will monitor to ensure there are no further issues.

Sun, Aug 10, 2025, 07:40 AM(18 minutes earlier)

Investigating

Barclays is experiencing an unplanned downtime. As a result, Barclays will not appear on the list of institutions for Instant Bank Payments (on the payer’s side). We are monitoring the situation and will update at the earliest.

Sun, Aug 10, 2025, 07:23 AM(17 minutes earlier)