Complete
We're not observing any more errors. The bank is now available in the list of institutions.
In progress
We've observed that some requests are failing since the end of the maintenance. We've removed Chase from the list of institutions until we resolve the issue with the bank.
Complete
Maintenance has completed
In progress
Maintenance has started
Scheduled
We'd like to inform you that Chase bank will have a planned maintenance from 13:00 to 13:25 BST on July 31.
During this time, Chase bank will be unavailable in the list of Institutions meaning Instant Bank Payments related to this bank will be unavailable. This will be reverted once the maintenance is complete