Bank of Ireland maintenance period
Resolved

Institutions maintenance period has ended.

Sun, Jul 6, 2025, 10:03 AM
(1 month ago)
·
Affected components

No components marked as affected

Updates

Resolved

Institutions maintenance period has ended.

Sun, Jul 6, 2025, 10:03 AM

Identified

We'd like to inform you that Bank of Ireland bank will undergo planned maintenance from 00:00 to 10:00 UTC on the 6th July 2025. During this time, the option to use Bank of Ireland for IBP will be disabled.

Sat, Jul 5, 2025, 11:41 PM(10 hours earlier)