Issues with HSBC
Resolved·Degraded performance

We're happy to report that the issues with HSBC payment processing have now been resolved. Payments are now flowing normally. We appreciate your patience while we worked with HSBC to address this.

Tue, Jun 24, 2025, 03:44 PM
(1 month ago)
·
Affected components
HSBC
Updates

Resolved

We're happy to report that the issues with HSBC payment processing have now been resolved. Payments are now flowing normally. We appreciate your patience while we worked with HSBC to address this.

Tue, Jun 24, 2025, 03:44 PM

Investigating

Since the planned maintenance from HSBC side, they are still facing issues. We will contact bank as soon as possible to get resolution.

Sun, Jun 22, 2025, 06:31 PM(1 day earlier)